Linux und Ich

Blog über Ubuntu, Linux, Android und IT

Lizenziert unter CC-BY von zoutedrop

Experimentelle Pakete für Alsa und PulseAudio

| 11 Kommentare

Über die ubuntu-devel Mailingliste bin ich vor ein paar Tagen auf das Ubuntu Audio Development Team aufmerksam geworden. Dieses Team kümmert sich um den Audio-Stack von Ubuntu und baut experimentelle Pakete mit den neusten Versionen. Seit Kurzem bietet es ähnlich wie das xorg-edgers-Team eine PPA-Paketquelle mit den neusten Versionen von Alsa und PulseAudio für Ubuntu Karmic und Lucid an.

Allerdings solltet Ihr die Quelle auf Keinen Fall nutzen, wenn Ihr keine Probleme mit dem Audiosystem Eures Rechners habt. Nur Leute mit Audio-Problemen, denen ein Upgrade auf die letzte Alsa-Version geraten wird, sollten diese Quelle als Strohhalm benutzen. Über…

$ sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
$ sudo apt-get update && sudo apt-get upgrade

…aktiviert Ihr die Paketquelle und aktualisiert das System.

Solltet Ihr Pakete aus der Quelle installiert haben und nicht zufrieden mit einem “Bleeding-Edge” Audiosystem sein, so könnt Ihr die Pakete recht leicht wieder entfernen. Informationen dazu findet Ihr unter hier Tipps zum Entfernen von PPAs inklusive der Deinstallation der aus Ihnen installierten Pakete.

Autor: Christoph

Hallo, ich bin Christoph -- Linux-User, Blogger und pragmatischer Fan freier Software. Wie Ihr ohne Zweifel bemerkt haben solltet schreibe ich hier über Linux im Allgemeinen, Ubuntu im Speziellen, sowie Android und andere Internet-Themen. Wenn du Freude an meinen Artikel gefunden haben solltest, dann kannst du mir über Facebook, Google+ oder Twitter oder natürlich dem Blog folgen.

11 Kommentare

  1. Christoph ist wieder da! Mein Leben hat wieder einen Sinn. Und der Blog sieht so… anders aus… Na ich überlege mir noch was ich davon halte :-)

    Wenigstens hat das neue Jahr wieder einen Sinn. Also dann sieh mal zu, dass Du die Anzahl der Beiträge, die Du deinen Fans schuldig geblieben bist, auch schnell wieder reinholst ;-)

  2. Übrigens ist die neue Seite nicht (wie unten behauptet) XHTML 1.1… Die W3 sagt da ziemlich deutlich “Errors found while checking this document as XHTML 1.1!”.

  3. Ich hab beim neuen Design nur “Ich will Kühe!!” gedacht ^^, na ja Geschmäcker sind unterschiedlich, hauptsache das Blog behält seine Qualität, herzlich willkommen zurück :).

    Was die XHTML Fehler angeht, scheinen die durch ne missglückte Konkatenation zu entstehen, sind alles Meldungen zu
    >
    ich denke das lässt sich finden/fixen ;).

  4. Hmmmm wohl irgend nen HTML Filter aktiv, gemeint war </sc’+’ript>>

  5. Ich kann übrigens auch nur jedem, der keine Probleme mit seiner Soundausgabe hat abraten, diese Fremdquelle zu nutzen! Es kann einem das gesamte Soundsystem zerlegen, darauf muss man sich einstellen.

    Dieses Risiko möchte man natürlich nur eingehen, wenn man ohnehin schon Probleme hat und diese anders nicht zu lösen sind.

  6. Ich war mutig – ich hab es installiert und das einige was passierte, es wurde Standart mässig Lauter d.h. ich kann meine Boxen jetzt auf minimum drehen und es reicht mir an Lautstärke xD

  7. Seit gestern oder vorgestern spielt mein Audiosystem komplett verrückt. Obwohl der PulseAudio-Lautstärkeregler entsprechende Ausschläge anzeigt, kommt weder ein Ton aus den Lautsprechern noch aus den Kopfhörern (je nachdem, was ich wähle).
    Gab’s in letzter Zeit irgendein Update für PulseAudio, welches dafür verantwortlich sein könnte? (Ich erinnere mich, dass ich vor ein paar Tagen aptitude safe-upgrade bemüht habe.)

  8. Hallo Simon, nicht dass ich wüsste. Wenn die Mixer Ausschläge anzeigen, dann wird das vermutlich auch nicht an Pulseaudio liegen. Ich würde mal schauen ob nicht irgendwelcher Mixer auf Stumm geschaltet sind. Hardware-Defekte sind auch nie gänzlich auszuschließen. Die Mikroschalter in den Klinken-Buchsen gehen gerne mal kaputt. Kannst ja auch mal mit der Ubuntu Desktop-CD booten (oder mit einer anderen Linux Live-CD). Dann kannst du ausschließen, ob es an deiner Installation liegt.

  9. Ich hab gerade mal einfach
    # pulseaudio -k
    # pulseaudio –start
    ausgeführt und mit einem Mal geht’s wieder. Sehr seltsam… Zumal ein Neustart des Systems diesen Fehler ja auch nicht behoben hatte…

    Danke aber für deine Antwort! Hardware-Fehler kann ich inzwischen jedoch getrost ausschließen, denn mein Headset hat eine eingebaute Soundkarte und, dass zwei Karten auf einmal ausfallen, ist relativ unwahrscheinlich. :)

  10. Pingback:   Experimentelle Soundtreiber für Ubuntu by + mzungu's weblog +

  11. Manchmal hatte ich, daß er immer auf Stumm war und ich ihn einschalten mußte (passierte nur wenn ich die 60 Sekunden abwartete und nicht sofort beenden geklickt habe!

Hinterlasse eine Antwort

Auf Linux und Ich darf anonym kommentiert werden. Die Felder für Name und E-Mail-Adresse dürfen beim Eintragen eures Kommentars leer bleiben. Ich freue mich aber über jeden Kommentar, zu dem der Autor mit seinem Namen steht.