Linux und Ich

Blog über Ubuntu, Linux, Android und IT

Spricht euer Ubuntu Quantal Quetzal auch chinesisch mit euch?

Spricht euer Ubuntu Quantal Quetzal auch Chinesisch mit euch?

| 15 Kommentare

Ich setzte hier auf meinen System schon eine ganze Weile die kommende Ubuntu-Version Quantal Quetzal ein. Irgendwo auf dem Weg durch die Alphas und Betas habe ich mir chinesische Sprachpakete eingefangen, deren Rückstände sich leider nicht mehr so einfach entfernen ließen. Überall wo die deutsche Übersetzung noch nicht vollständig war, aber die chinesische schon, tauchten auf meinem System chinesische Schriftzeichen auf, und auch beim Login war das Tastaturlayout verdreht. Über die Sprach-Einstellungen lies sich die Sprache leider nicht entfernen, die Lösung brachte zum Glück ein Eintrag bei Ask Ubuntu. Da ich nicht glaube der einzige mit dem Problem zu sein, gebe ich den Inhalt hier weiter.

In den Sprach-Einstellungen gibt es eigentlich ein Button zum Hinzufügen und Löschen von Sprachen. Leider führte dieser bei mir jedoch nur Deutsch und Englisch auf als installierte Sprachen auf, doch chinesisch fehlte. In der Paketverwaltung war auch nichts mit “ch” oder “zh” installiert, das auf ein Sprachpaket hindeutete. So war ich recht froh auf die passende Lösung im Netz zu treffen.

Über den Button Sprachen hinzufügen/entfernen lässt sich die chinesische Sprache nicht entfernen.

Schaut euch erst einmal die auf eurem System installierten locale-Einstellungen an. Der Befehl localdef listet die entsprechenden Einstellungen auf. Im meinem Fall zeigen zh_CN.utf8 und zh_SG.utf8 dass ich Sprachen auf dem System habe, auf die ich eigentlich verzichten möchte.

$ localedef --list-archive
[...]
zh_CN.utf8
zh_SG.utf8

Kickt nun die beiden Sprachen aus den Locales raus und erzeugt diese neu. Ihr solltet jetzt sehen, dass nur noch Deutsch und Englisch (plus weitere von euch installierte Sprachen) erneut gebaut werden, die chinesischen Locales sollten jetzt allerdings auf jeden Fall fehlen.

$ sudo localedef --delete-from-archive zh_CN.utf8
$ sudo localedef --delete-from-archive zh_SG.utf8
$ sudo locale-gen
Generating locales...
  de_AT.UTF-8... done
[...]
  en_AG.UTF-8... up-to-date
[...]
Generation complete.

Prüft nun in der Datei ~/.pam_environment, ob sich nicht doch eine Einstellung in den Umgebungsvariablen eurer Sitzung gehalten habt. Sollte hier noch einmal etwas in der Richtung zh_CN auffallen, dann öffnet die Datei in einen Editor und schmeißt die entsprechende Passage raus.

$ cat ~/.pam_environment
LANGUAGE=de_DE:zh_CN:en
LANG=de_DE.UTF-8
$ sudo locale-gen

Danach noch einmal die Locales generieren, und schon sollte das System nur noch Deutsch und im Notfall Englisch speachen. Wann genau das Problem zum ersten mal auftrat, kann ich leider nicht mehr sagen, doch nach der Aktion sollten die Sprachen wieder bis zur nächsten Testphase stimmen :) Vielleicht hilft der Beitrag ja jemandem, dem es genauso ging wie mir…

Autor: Christoph

Hallo, ich bin Christoph -- Linux-User, Blogger und pragmatischer Fan freier Software. Wie Ihr ohne Zweifel bemerkt haben solltet schreibe ich hier über Linux im Allgemeinen, Ubuntu im Speziellen, sowie Android und andere Internet-Themen. Wenn du Freude an meinen Artikel gefunden haben solltest, dann kannst du mir über Facebook, Google+ oder Twitter oder natürlich dem Blog folgen.

15 Kommentare

  1. Vielen Dank! Ich hatte mich schon gewundert.

    Ich hatte in Precise Pangolin vor einiger Zeit dasselbe Problem und hab dann einfach im Auswahldialogfenster für Systemsprachen Chinesisch – wenn ich mich richtig erinnere – auf den letzten Platz verbannt, sodass mir dann auch keine Strings mehr auf Chinesisch angezeigt wurden. Der Eintrag hat aber trotzdem weiterhin existiert, obwohl keine entsprechende Locale installiert war, wie du im Artikel geschrieben hast.

  2. Hey danke für den Tipp, das ist in der Tat auch bei mir passiert. Manchmal hab ich nach dem Einloggen das ganze System auf chinesisch (dachte es wäre japanisch) gehabt. Mal sehen ob das jetzt gar nicht mehr passiert.

  3. Wie schon Carsten im ersten Kommentar schrob – das scheint in der Tat kein Problem speziell von Quantal zu sein. Habe mir beim Lesen des Beitrags direkt mal die localedef auf meinem System (Precise) angeschaut, und siehe da, zh_CN und zh_SG. Ist mir in den Spracheinstellungen unter Gnome bisher gar nicht aufgefallen, da ganz am Ende der Liste… Nixdestoweniger auch von mir danke für den Tip. :)

  4. Ist mir auch schon bei der aktuellen LTS passiert und weil die Tastatur auf Grund des Layouts nicht mehr zu benutzen war und auch die deutschen und englischen Sprachpakete nicht mehr zu aktivieren waren, blieb mir nichts anderes, als eine Neuinstallation. Und ich habe keinen blassen Schimmer, wie das passiert ist. Es handelte sich übrigens um eine lediglich als Office- und Internet-genutzte Arbeitsumgebung. Also alles andere als eine Testumgebung mit einer Vielzahl von Installationen und Paketquellen…

  5. Hast du mal localepurge ausprobiert? Eventuell muss man dann nicht so viel manuell rumschrauben.

  6. Ich hatte das Problem neulich auch unter der aktuellen LTS, die Lösung war aber viel einfacher, einfach das Englisch in den Spracheinstellungen mit der Maus fassen und über das Chinesisch ziehen und alles war wieder in Ordnung.

  7. Nein das Problem hatte ich noch nicht. Oder konnte ich noch nicht haben. Denn die Nvidia Geforce GS 8600M meines Laptops wird nicht erkannt. Sobald Unity startet sehe ich nur schwarz/Weiß Kacheln und die Oberfläche wird unbenutzbar. Weiß jemd, was dagegen hilft?

  8. Danke für den Entfern-Tip. Das Phänomen ist mir in letzter Zeit schon bei mehreren Distributionen mit auf Gnome basierenden Desktops aufgefallen, nicht nur Ubuntu. Oft sieht man schon bei den entsprechenden Live-Medien in den Spracheinstellungen ausgegrautes nicht entfernbares chinesisch, das ungefragt in die Installation übernommen wird.

  9. Vielen Dank. Hat super geklappt! Bevor ich deinen Beitrag fand dachte ich schon ich müsste mich mit den asiatischen Zeichen abfinden oder an der VHS chinesisch lernen.

    Grüße, Andi.

  10. Super Tipp mal wieder! Danke!

  11. Vielen Dank für den Tipp !
    Wie gesagt, dieser Umstand ist mir auch schon länger aufgefallen,
    nur hat es eben heute bei einer Linux-Mint-Inst. (14) auf einem Notebook ganz gewaltig gehappert. Deswegen bin ich auf die Suche gegangen.
    Vielen Dank für die fachliche Hilfe und den Tipp.

  12. Hallo Christoph,
    fast immer wenn ich auf der Suche nach einer Lösung bin lande ich bei
    Dir mi Block.Mit Deinen Beiträgen hast Du mir schon sehr oft geholfen.
    Danke !!!
    Du kannst mir doch ganz bestimmt ein Tipp geben wie ich Screenshot
    in Evolution einbinden kann (nicht als Anhang)Bei mir sind die Bilder zum einfügen viel zu groß.Im voraus. vielen ,vielen Dank.
    Ganz herzlich liebe Grüße
    Jens

    • Hallo Jens, wenn du kleinere Screenshots verschicken willst, dann skalieren Sie mit einem Graphikprogramm wie Gimp herunter oder schneide nur den Bereicht aus, den du haben willst. Sehr praktisch für Screenshots ist das Programm Shutter. Grüße, Christoph.

  13. Vielen Dank, das hat mein Problem schnell gelöst.

Hinterlasse eine Antwort

Auf Linux und Ich darf anonym kommentiert werden. Die Felder für Name und E-Mail-Adresse dürfen beim Eintragen eures Kommentars leer bleiben. Ich freue mich aber über jeden Kommentar, zu dem der Autor mit seinem Namen steht.