Linux und Ich

Blog über Ubuntu, Linux, Android und IT

Troubleshooting Adobe Flash in Ubuntu

Troubleshooting Adobe Flash in Ubuntu

| 45 Kommentare

Ich sehe oft, dass User selbst bei der aktuellen Version von Ubuntu Schwierigkeiten haben Flash-Animationen im Webbrowser abzuspielen. Im Laufe dieses Beitrages versuche ich ein paar Trick&Tipps zu geben, so dass jeder Ubuntu User schnell Flash zum laufen bekommt… Dabei ist es eigentlich wirklich einfach Flash mit Ubuntu zu benutzen. Es muss nur das Paket flashplugin-nonfree über die Paketverwaltung installiert werden und Flash sollte laufen.

Dies geht sogar wunderbar über die graphischen Frontends der Paketverwaltung, also “Anwendungen -> Hinzufügen/Entfernen” öffnen, “Alle verfügbaren Anwendungen” anzeigen lassen und nach flash suchen. Flash versteckt sich dann hinter “Macromedia Flash plugin”.

Über Anwendungen -> Hinzufügen/Entfernen sollte die Installation von Adobe Flash ein Kinderspiel sein.

Über Anwendungen -> Hinzufügen/Entfernen sollte die Installation von Adobe Flash ein Kinderspiel sein.

Dennoch kommt es immer wieder zu Problemen. Ich möchte hier kurz die üblichen Fehlerquellen und Abhilfen auflisten, so dass Ihr Euch selber helfen könnt. :)

Flash Alternativen kommen sich in die Quere

Mit Gnash und Swfdec gibt es freie Alternativen zum proprietären Adobe Flash. Die Entwicklung dieser Alterntiven ist mitterlweile sehr weit. So funktioniert beispielsweise YouTube mit Swfdec schon erstaunlich gut, doch noch sind die Entwickler nicht am Ende ihrer Ziele. Manche Dinge klappen mit Gnash oder Swfdec noch nicht so gut wie bei Adobe Flash.

Manch ein Anwender installiert sich nun aus Versehen oder Unkenntnis Gnash oder Swfdec, so dass das System nun die freien Alternativen anstatt Adobe Flash benutzt. Man kann dies sehr leicht austesten. Mittels “dpkg -l paketname” kann man Abfragen ob ein Paket installiert wurde. Im Falle von Flash, sollte das Ergebnis so

$ dpkg -l flashplugin-nonfree mozilla-plugin-gnash swfdec-mozilla
[...]
ii  flashplugin-nonfree      10.0.1.218+10.0.0.525ubu Adobe Flash Player plugin installer
Kein Paket gefunden, das auf mozilla-plugin-gnash passt.
Kein Paket gefunden, das auf swfdec-mozilla passt.

aussehen. Das “ii” bedeutet, dass Adobe Flash über das Paket “flashplugin-nonfree” installiert wurde. Swfdec und Gnash wurden nicht installiert. Sollte das Ergebnis bei Euch anders aussehen, so müssen die Alternativen deinstalliert und Adobe Flash installiert werden. Mittels

$ sudo apt-get remove mozilla-plugin-gnash swfdec-mozilla
$ sudo apt-get install flashplugin-nonfree

muss dies funktionieren.

Unterschiedliche Adobe Flash Versionen

Das Adobe Flash Browser-Plugin liegt, wenn es über die Paketverwaltung installiert wurde, im Verzeichnis /usr/lib/flashplugin-nonfree/. Doch der Webbrowser sucht nicht nur hier nach möglichen Plugins. So durchsucht bspw. Firefox das eigene Profil im Homeverzeichnis des Benutzers, also in ~/.mozilla/plugins ebenfalls nach einem Plugin.

Liegt nun irgendwo eine ältere Version des Flash-Plugins, so wird eventuell diese benutzt und eine neuere Version, die über die Paketverwaltung installiert wurde, nicht. Daher sollte man nach weiteren Versionen der Datei libflashplayer.so suchen. Dies kann man sehr schnell mittels “locate” machen.

$ sudo updatedb            # locate Datenbank aktualisieren
$ locate libflashplayer.so  # Mit locate nach libflashplayer.so suchen
/usr/lib/flashplugin-nonfree/libflashplayer.so

Sollte hier mehr als nur der Treffer in /usr/lib/flashplugin-nonfree/ erscheinen, so sollte man diese Dateien löschen oder umbenennen. Üblich sind beispielsweise Treffer in /home/username/.mozilla/plugins. Dies wäre ein Flash-Plugin, das sich im Profil von Firefox eingenistet hat.

Kein Ton in Flash-Animationen oder Videos?

[UPDATE 26.04.09] Seit Ubuntu Intrepid Ibex wird von Haus aus Adobe Flash 10 auf einem Ubuntu System installiert. Dieses hat keine Probleme mehr mit PulseAudio, das Paket libflashsupport ist von daher unnötig. Es sollte daher nicht mehr installiert werden. Wer mit Flash 10 noch keine Sounds hört, der sollte sich den Beitrag Sounds mit PulseAudio umleiten ansehen. Oft muss Flash nur die richtige Soundkarte zugewiesen werden. Der folgende Abschnitt gilt also nur noch für Ubuntu Hardy Heron 8.04…[/UPDATE]

Nun das letzte Kapitel. Ubuntu benutzt seit der Version Hardy Heron 8.04 den Soundserver PulseAudio. Adobe Flash 9 kann mit PulseAudio noch nicht kommunizieren. So kommt es vor, dass ein Flash-Video weitere Anwendungen daran hindert Klänge oder Sounds abzuspielen bzw. wenn schon andere Programme Klänge abspielen, so bleibt das Flash-Video stumm. Man kann sich damit helfen, dass man das Paket libflashsupport installiert.

$ sudo apt-get install libflashsupport

Dieses beinhaltet mehrere Ausbesserungen, so dass Adobe Flash nun Sound über PulseAudio abspielen kann und somit auch nicht mehr die Soundkarte blockiert. Ich hoffe, dass Flash nun bei Euch läuft.

//PS: Ein kleiner Disclaimer: Direkt nach dem Release von Ubuntu Hardy Heron 8.04 im April 2008 sorgte libflashsupport für zahlreiche Abstürze des Browsers. Sobald das Paket installiert war, wurde aus Internetsurfen Glückspiel… Mittlerweile sind die Probleme jedoch wohl gelöst. Auf keinen meiner Systeme kann ich solche Abstürze nun nachvollziehen. Sollte also Eurer Browser auf einmal Instabilitäten aufweisen, so sagt nicht ich hätte Euch nicht gewarnt ;)

Letzter Ausweg: Flash 10 Beta

[UPDATE 26.04.09] Adobe Flash 10 hat schon länger den Betastatus verlassen und wird von Haus aus bei allen Ubuntus über die Paketverwaltung installiert. Interessant ist dieser Abschnitt noch für Leute, die ein 64-bit Ubuntu betreiben. Die Beta der 64-bit Version von Adobe Flash 10 muss noch immer von Hand installiert werden.[/UPDATE]

Sollten alle Stricke reißen und man hat nun immer noch kein ordentlich laufendes Adobe Flash auf dem Rechner, so gibt es noch die Möglichkeit die kommende Version von Adobe Flash zu testen. Adobe gibt die Betas im laufe der Zeit regelmäßig frei. Viele Benutzer berichten viel Positives von Flash 10. Unter anderen scheinen PulseAudio und Adobe Flash 10 Beta nun gut miteinander auszukommen.

Die Installation auf einem 32-bit Ubuntu ist nicht schwer. Man lädt sich von der Adobe Labs Webseite Flash 10 als .tar.gz Archiv herunter, entpackt es und ersetzt die Datei /usr/lib/flashplugin-nonfree/libflashplayer.so mit der libflashplayer.so aus dem Archiv. Starte man nun den Browser, so sollte Flash 10 genutzt werden. Wer ein 64-bit Ubuntu benutzt, der muss etwas mehr Aufwand betreiben

Keine Mausklicks in Ubuntu Karmic Koala möglich

[UPDATE 23.10.09] In Karmic gibt es das Phänomen, dass Schaltflächen in Flash-Videos, Spielen oder Animationen nicht angeklickt werden können. Man merkt dies etwa an YouTube, wo man das Video nicht pausieren oder den Scrollbalken nicht verschieben kann. Schuld daran ist wohl Compiz. Über die Installation des Paketes libadns1 kann man Abhilfe schaffen…

$ sudo apt-get install libadns1

…weitere Informationen findet man im Bug #410407 auf Launchpad.[/UPDATE]

Autor: Christoph

Hallo, ich bin Christoph -- Linux-User, Blogger und pragmatischer Fan freier Software. Wie Ihr ohne Zweifel bemerkt haben solltet schreibe ich hier über Linux im Allgemeinen, Ubuntu im Speziellen, sowie Android und andere Internet-Themen. Wenn du Freude an meinen Artikel gefunden haben solltest, dann kannst du mir über Facebook, Google+ oder Twitter oder natürlich dem Blog folgen.

45 Kommentare

  1. Hi,

    hab grad noch mal in der Paketverwaltung gesucht und es sind wirklich nur ‘flashplugin-nonfree’ und ‘libflashsupport’ installiert. Abstürze hab ich aber trotzdem noch :(

    8.04 + Gnome + alles auf aktuellstem Stand

    Naja, frustrierend, aber auszuhalten. Totem mit Youtube-Plugin macht keine Zicken.

    MfG

  2. Grummel, liegt das am Grafiktreiber? Ich würde dann empfehlen auf Flash 10 Beta umzusteigen. Man kann die Beta von hier herunterladen. Das .tar.gz Archiv entpackt man und ersetzt die /usr/lib/flashplugin-nonfree/libflashplayer.so mit der libflashplayer.so aus dem Archiv.

  3. Pingback: Kurz verlinkt: Christophs kleine Flash-Nachhilfestunde « Ubuntu Observer

  4. Alles klar, so geht es wunderbar bei mir. Zum Test war ich heute mal extralange auf Youtube unterwegs und hatte keinen Absturz.

    Vielen lieben Dank, dieser Bug war manchmal richtig nervend.

    Max

  5. Gut, ich hab das noch in den Blog eingebaut :)

  6. Hi,

    leider gibts trotz Beta 10 immer noch Abstürze bei myspace .. gerade wenn viele Flashanimationen auf der Seite sind und der myspace-player funktioniert auch noch nicht richtig mit der beta .. naja abwarten und tee trinken..

    gruß
    philbert

  7. Hallo Philbert, kannst du mir sagen was für eine Grafikkarte du hast und welchen Treiber du für sie benutzt. Auch interessant wäre ob du PulseAudio oder Alsa als Soundserver eingestellt hast.

  8. Hi Christoph,

    auch ich habe das Flashpaket aus den Ubuntu Quellen sowie “libflashsupport” installiert. Trozdem stürzt mein Firefox alle 10 Minuten ab.

    Auch mit der Beta des Flashplayer 10 habe ich diese Probleme.

    Nichtmal auf Seiten die auf den ersten Blick kein Flash nutzen kann man sich sicher fühlen weil viele Werbebanner Flash sind.

    Wirklich sehr sehr ärgerlich, vorallem als YouTube-Liebhaber. Ich hoffe einfach das es bei 9.04 beim Release alles ohne Probleme funktioniert.. das ist wirklich sehr ärgerlich.

  9. @Kevin
    Hmmm, was für eine Grafikkarte hast du? Welchen Treiber nutzt du für sie? Irgendwie muss da der Grafiktreiber mit ins Spiel kommen. Ich habe Rechner mit Nvidia und Intel Karten, keine Probleme…

  10. Hallo nochmal, sorry das die Reaktion jetzt erst kommt.
    Ich habe eine Nvidia Geforce 7300 GT mit dem richtigen Treiber aus dem Quellen (compiz, spiele etc. funktioniert alles wunderbar).

    Ich habe das mittlerweile so gelöst das ich alles komplett auf ALSA umgestellt habe.

    naja das problem hat sich dann hoffentlich mit dem 8.10 release in wenigen tagen erledigt.

    Trozdem danke für deine Bemühungen.

  11. Hilfe! Kubuntu 8.10 + Adobe Flash 10 + on Board VIA Soundkarte + USB Lautsprecher – Kein Sound bei Flash Videos!

    Hi!

    Ich beiße mir an oben genannter Konfiguration die Zähne aus um Flash Videos (z.B. You Tube) auch zu hören statt nur zu sehen.

    Ich kann MP3′s mit Amaork hören, Filme mit Ton, alles kein Problem. Nur noch mit Flash Videos im Firefox klemmt’s. Muss ich ggf. noch irgendwie irgendwo noch was einstellen, evtl. wie z.B. bei Amarok bei mono / Stereo hw:1 hinterlegen?

    Habe auch schon unterschiedlichste Lösungsversuche aus Foren etc. probiert.

    …helft mir Obiwan, ihr seit meine letzte Hoffnung :-)

    Thx for Support

    Andinger

  12. Hi Andinger,

    habe das gleiche Problem mit Hardy Ubuntu + Adobe Flash 10 (es wird allerdings immer 9.0.xxx angezeigt) + Alsa + onBoardSound cMedia.

    Auf den Youtube-Seiten wird immer wieder angezeigt, ich soll Flash installieren.

    Habe alle (wirklich alle) Anweisungen / Vorschläge von oben ausprobiert. Alles installiert / deinstalliert, usw. ES KLAPPT NICHT.

    Selbst wenn ich “von vorn” anfangen möchte und mit der DeInst. von “flsch-nonfree” beginne, zeigt mir “dpkg -l” immer noch an, dass flash installiert ist.

    VErzweifelt….

  13. @Andinger
    Die USB-Boxen sind stellen quasi eine eigene Soundkarte da. Ich kenne mich mit den Dingern leidern nicht aus, erst recht nicht mit KDE4…

    @Merlin69
    Bis gestern gab es ein Problem mit Adobe Flash in Hardy. Adobe hat die URL zum Archiv mit Flash geändert, so dass es nicht mehr heruntergeladen werden konnte. Bitte führe

    sudo rm /var/cache/flashplugin-nonfree/*
    sudo apt-get install --reinstall flashplugin-nonfree
    

    aus. Es sollte dann klappen. Zwei Flash Versionen solltest du generell nicht installiert haben. Entscheide dich für Adobe Flash 10, das du über die Homepage von Adobe als .deb Paket herunterladen kannst, oder für Adobe Flash 9, das du über die Paketverwaltung als Paket flashplugin-nonfree installierst. Aber bitte nicht beides installiert lassen.

  14. hi christoph u rest

    hatte bis grad auch probleme mit ubuntu 8.10 und dem adobe flash 10.
    habe wie in deiner vorgabe alles bereinigt und dann adobe 10 mit flashplugin-nonfree und flashplugin-nonfree-extrasound (ausm anderen forum erfahren, dass das nötig ist) installiert.
    ging immer noch nicht.

    er hat zwar im /usr/lib den flashplugin-nonfree ordner angelegt, die libflashplayer.so aber nicht in diesen eingefügt.
    warum weiss ich nicht.
    nachdem ich die libflashplayer.so dann per hand eingefügt hab geht jetzt endlich alles wunderbar.
    vielleicht kannst du das ja auch noch in deine beschreibung einfügen, kontrolle ob in den verzeichnissen auch die libflashplayer.so angekommen ist.

    lg

    mo

  15. Hallo Christoph,

    bin heute auf deine tolle Seite gestoßen, und habe schon ne ganze Weile gestöbert. Besonders interessant fand ich diesen Artikel.

    Habe mit Ubuntu (der noch unfertigen Jackalope Version) leichte Probleme mit Flash im Vollbild Modus. Es kommt zu Rucklern und kurzen Aussetzern, obwohl es von der Hardware her nicht an Leistung mangelt. Nachforschungen ergaben eine Auslastung von über 70% beider! Kerne meines Pentium Dualcores.

    Liegt das an schlechter Programmierung seitens Adobe, oder an meinem stümperhaft konfiguriertem System?

    Ich habe nachgeschaut, es ist ausschließlich das flashplugin-nonfree installiert, und auch die lib befindet sich nur einmalig auf dem System.

    Für Tipps wäre ich dankbar.

    Gruß
    Jan

  16. @mo
    Nein flashplugin-nonfree-extrasound ist eigentlich nicht nötig. Es enthält Plugins für OSS und Esound. Flash sollte eigentlich direkt mit deinem PulseAudio-Server sprechen können.

    Bist du sicher dass bei der Installation des Paketes flashplugin-nonfree alles richtig geklappt hat. Bedenke dass das Paket die libflashplayer.so NICHT enthält. Diese wird bei der Installation des Paketes aus dem Netz geladen, auf Fehler oder Veränderungen geprüft und dann erst kopiert.

    Dabei kann es zu Problemen kommen. Ändert Adobe das herunterzuladende Archiv, so schlägt das überprüfen der Prüfsumme fehl und Flash wird nicht installiert obwohl das Paket flashplugin-nonfree installiert wurde. Ich empfehle bei Flash immer die Installation über ein Terminal und apt-get.

  17. @Jan
    Das mit dem Vollbild kenne ich auch. Ich denke es ist ein Zusammenspiel von Grafiktreiber und Adobe Flash. Ich habe mehrere Systeme. Eines mit Nvidia-Karte, das andere mit einem Intel-Chipsatz und eine von ATI.

    Auf dem System mit der Karte von Nvidia ruckelt das Vollbild nicht, aber es ist auch nur so groß wie das Video im “Normalbild” und verschwindet gleich wieder, auch wenn ich die Maus nicht bewege. Beim System mit der Intel-Karte klappt alles. Und beim ATI-System kommt es zum von dir beschriebenen Ruckeln.

    Daher: Adobe verfügt über einen öffentlichen Bugtracker… bugs.adobe.com. Du kannst imho nicht mehr machen als zu recherchieren ob das schon als Bug gemeldet ist (was vermutlich schon getan wurde) und abzuwarten.

  18. hi christoph,
    du hast recht, terminal hat die als fehler ausgegeben, dass das plug-in nicht installiert werden konnte, wegen der prüfsumme. habe aber alles über apt-get installiert, trotzdem wurde es nicht gefunden.
    deshalb eben der vorschlag, in der anleitung zu vermerken, lieber noch mal selbst im ordner nachschauen, ob was angekommen ist.
    und notfalls reinkopieren. wie gesagt hab da mehrere tage mit zugebracht und mehrere nerven verloren, weil ich dachte dass alles installiert ist.
    ordnercheck hätte nur ne sekunde gedauert…

    feine seite übrigens

    mo

  19. Hallelujah – es geht endlich. Vielen Dank.

  20. Hallo Christoph,
    Kompliment für die gepflegte, interessante und ästhetische Web-Site. Klasse Tips! Ich bin beim Suchen drauf gestoßen, weil mein Flash-Player unter Intrepid und Firefox 3.0 immer stumm blieb (x86 mit GeForce 8300 GS). Leider hat keiner Deiner Kniffe zum Erfolg geführt – es gab keinen Ton. Seit Jaunty sieht aber alles anders aus. Ich verwende Pulse-Audio, habe das Macromedia-Flash-Plugin in der Anwendungsverwaltung deaktiviert und “dpkg -l flashplugin-nonfree mozilla-plugin-gnash swfdec-mozilla” zeigt noch nicht mal ein plugin an:
    “pn flashplugin-no (keine Beschreibung vorhanden)
    pn mozilla-plugin (keine Beschreibung vorhanden)
    pn swfdec-mozilla (keine Beschreibung vorhanden)”
    Ich versteh’ nicht recht warum, aber der Flashplayer läuft einwandfrei in Bild&Ton!!! Mein Tip also: Jaunty!
    mit freundlichem Gruß
    us

  21. Hallo Ulf. Vielen Dank für die netten Blumen. Solche Kommentare freuen das Blogger-Herz umso mehr :) Wahrscheinlich liegt das Flash-Plugin in deinem Homeverzeichnis, schau dir mal den Abschnitt “Unterschiedliche Adobe Flash Versionen” aus diesen Beitrag hier an, wahrscheinlich liegt die libflashplayer.so unter ~/.mozilla/plugins.

    Zum Thema Sound und Adobe Flash habe ich unter Sounds mit PulseAudio umleiten einen Beitrag, der dir eventuell hätte weiterhelfen können. Eventuell wurde der Sound von Flash einfach nur zur falschen Soundkarte geschickt. Aber jetzt tut ja alles :)

  22. Hallo,

    weiter oben wurde ja schon genannt, dass die Qualität der Funktionsweise vom Zusammenspiel Adobe Flash und Grafiktreiber zusammenhängen. Gibt es denn bestimmte xorg.conf-Einstellungen, die für eine angenehme Performance mit Flash notwendig sind?

  23. @Thomas, nein, sicherlich keine “speziellen”. Um was für eine Grafikkarte und welches OS gehts denn?

  24. Du bist ja schnell. :-)

    Es geht um modernere Nvidia Grafikkarten,Intel-Chipsätze (eeepc 901go), Sidux und Ubuntu 32&64

    Eine Performancesteigerung konnte ich jetzt schon herbeiführen, in dem ich mich bei Ubuntu auf das Paket “adobe-flashplugin” beschränkte und flashplugin-installer flashplugin-nonfree (alles die gleiche Version). Irrtümlich installierte ich alle drei Pakete in der Vermutung, es sei notwendig.

    Naja, irren ist menschlich und ich bin sicherlich nicht der Einzigste der die Installation so gehandhabt hat.

    Zufrieden bin ich trotzdem noch nicht und würde mich sehr über Optionen für Nivdia und Intel-Grafik (eeepc 901go) freuen

  25. Ich hab zwar keine groben Ruckler, aber die performance lässt doch zu wünschen übrig. Es kann mir nicht vorstellen, dass die hardware zu schwach ist. Mit meiner alten 1 GHZ krücke und ner gforce 2 gts, lächerlich wenig ram, hatte ich zb bei http://www.sauspiel.de ordentliche performance.

    jetz hab ich über 2ghz, ne gforce 6800 gt und n Gig Ram und ubuntu 9.04. Ich bin zwar davon überzeugt, dass linux nicht zum spielen da ist, dennoch, hin und wieder allerdings G

    ich hab das adobe_flashplugin v10 korrekt installiert, und performanceprobleme beim firefox, opera und ephiphany.

    laut glxinfo funktioniert mein handware rendering, bei glxgears komm ich auch auf ganz ordentliche werte. seit einem monat recherchier ich zu dem thema, und wenn ich überhaupt antworten finde, dann besagen diese “is halt so, find dich damit ab”. begründung ist, dass flash nicht hardwarerendern kann, wobei ich allerdings schon des öfteren gegenteiliges gelesen habe.

    eigentlich will ich auch gar keinen dazu auffordern, eine lösung für diese eher unwichtige problem zu finden. mein jaunty läuft stabil, ich kann alle meine arbeiten wunderbar machen.

    aber trotzdem würd ich gern noch einige meiner freunde überzeugen, auf linux umzusteigen. aber wenn noch nicht mal einfache flashgames funktionieren und youtube das system merklich belastet, hab ich da keine chance.

    und an die anderen geplagten, die sich daran ärgern, dass das problem als “gelöst” abgestempelt wird: Ihr seid nicht allein!

  26. ach ja und andere plugins / libflashplayer.so sind auch nicht auf meinem rechner. das stimmt alles.

  27. vielen dank! es funktionier jetzt :D
    weiter so! :D

  28. danke für diese tolle Website, hatte schon seit der Ubuntu-Installation Probleme mit dem flash-plugin, jetzt weiss ich dass es nur am swfdec-player lag, hab ihn entfernt und nun klappt alles!!

    danke tausend Mal!!

  29. Hallo!
    Ich habe auf meinem neuen Rechner Ubuntu ganz frisch installiert.Obwohl ich meinem alten Rechner Flash Problem einwandfrei selber behoben habe, hat es dieses Mal nicht geklappt und seit gestern bin ich am Rumfummeln im Internet…Lange lange gegooglet, die üblichen Foren durchgesucht und endlich mal auf Ihr Blog gekommen…
    Bis jetzt habe einige Codes von Foren abgetippt, egal ob ich die vollkommen verstanden habe…
    Aber hier ging es Blitzschnell!
    Noch leichter und verständlicher könnte man nicht beschreiben, wie man sich mit Adobe bzw. allen anderen Flash Player umgehen kann!

    Ich bedanke mich vielmals!
    Mit Freundlichen Grüßen,
    Emre

  30. Hallo!
    Ich habe das Problem, dass Flash-Anwendungen, wie der myspace-Player oder ein Video auf southpark.de ein Hängenbleiben oder einen Absturz des Firefox verursachen oder sogar den kompletten PC ausschalten. Hab mich bei ubuntuusers durchs Forum gelesen und bin so auch auf diesen toll geschriebenen Blog-Eintrag gestoßen. Habe das oben Geschriebene abgearbeitet, doch ich weiß immer noch nicht was schief läuft. In den Kommentaren hier habe ich gelesen, dass die Information, welche Grafikkarte, welchen Grafiktreiber und welchen Soundserver man nutzt wichtig ist. Wie finde ich heraus welchen Grafiktreiber und welchen Soundserver ich nutze? Werde es dann unter “Flash stürzt ab” posten.
    Vielen Dank :)

  31. Vielen Dank, auch mir hat das hier geholfen. Hatte aus Versehen dieses swfdec installiert. Flash ging teilweise und dann doch wieder nicht. Dachte schon, ich sei doof :D

  32. SUPER! Vielen Dank! Es war bei mir der offizielle Adobe Treiber und swfdc, die sich da wohl in die Quere kamen. Jetzt kann ich heute abend die Wahlberichterstattung live mitverfolgen :)

    Nochmal Danke und viele Grüße

    Marc

  33. Hallo
    Probleme mit Adobe Flashplayer.
    Fehlermeldung
    E: Das Paket adobe-flashplugin muss neu installiert werden, ich kann aber kein Archiv dafür finden.
    Das Paket »adobe-flashplugin« ist in einem inkonsistenten Zustand und muss neu installiert werden, aber es wurde kein Archiv dafür gefunden. Dieses Paket jetzt entfernen um fortzufahren?
    dpkg: Warnung: Problem wir übergangen, weil –force angegeben ist.

    Kann mir jemand helfen?
    Vielen Dank

  34. Hallo stiefel, deinstalliere das Paket adobe-flashplugin und installiere Flash über die Paketverwaltung

    $ sudo apt-get remove --purge adobe-flashplugin
    $ sudo apt-get install flashplugin-installer
    

    //PS: Da du nicht sagst welche Ubuntu-Version du benutzt, kann ich nur raten. Egal wo du zum Thema Linux nach Hilfe fragst, gib immer deine Distribution und deren Version an :)

  35. Hallo, ich habe das gleiche problem, habe die statements aus vorigem kommentar eingegeben. Errormeldung bleibt:
    E: Das Paket adobe-flashplugin muss neu installiert werden, ich kann aber kein Archiv dafür finden.
    ubuntu 9.10 ist installiert.

    Was kann ich tun?
    Danke.

  36. Hall KMN, das ist ja eher ein Paketverwaltungs-Problem als ein Thema rund um Flash. Bitte starte mal bspw. auf uu.de einen Thread. Generell sollte das Flashplugin via flashplugin-installer via der Paketverwaltung von Ubuntu und nicht über das Paket adobe-flashplugin von Adobe selber installiert werden…

  37. Ein Dank an Christoph.

  38. Unterschiedliche Adobe Flash Versionen

    linuxundich.de:
    “Sollte hier mehr als nur der Treffer in /usr/lib/flashplugin-nonfree/ erscheinen, so sollte man diese Dateien löschen oder umbenennen. ”

    ubuntuusers.de:
    “Sollte hier mehr als nur die Treffer in /usr/lib/flashplugin-installer/ und /usr/share/ubufox/plugins/ erscheinen, so sollte man diese Dateien löschen oder umbenennen (Ausnahme: /var/cache/flashplugin-nonfree/libflashplayer.so).”

    Welche Aussage ist nun “richtiger” ?

    • Die Aussage von ubuntuusers.de ist aktueller. Seit Intrepid heißt das Paket flashplugin-nonfree jetzt flashplugin-installer. Somit ändern sich auch die Pfade.

      • Sorry, habe es falsch vormuliert.

        Bei dir heißt es “mehr als nur ein Treffer” und bei uu.de heißt es “mehr als nur die Treffer”.
        Gibt es also in der neuen Version 2 “libflashplayer.so” Dateien?

  39. Zitat: Über die Installation des Paketes libadns1 kann man Abhilfe schaffen…

    DANKE DANKE DANKE DANKE!!!! Es geht wieder.

  40. Hallo,

    Ich arbeite schon ein knappes Jährchen mit Ubuntu und komme auch recht gut klar, allerdings bezeichne ich mich selbst immernoch als Noob auf dem Pinguin-Gebiet ;)
    Somit habe ich es bei vielen Sachen auch noch recht schwer, wie bei meiner folgenden Frage:
    Habe auf meinen Hauptrechner jetzt Ubuntu 11.04 64Bit aufgesetzt und alles läuft. Nur Flash Applikationen im Firefox (hauptsächlich) im Vollbild laufen nicht unbedingt flüssig, soll heißen, sie ruckeln, oder reagieren nicht in Echtzeit.
    Nun habe ich mal weiteren Flash Installationen gesucht und meiner Meinung nach ist da auch alles ok. Bis auf den “locate” Befehl, da bin ich mir unsicher. Hier die Ausgabe:
    “locate libflashplayer.so

    /usr/lib/flashplugin-installer/libflashplayer.so
    /usr/share/ubufox/plugins/npwrapper.libflashplayer.so
    /var/lib/flashplugin-installer/npwrapper.libflashplayer.so”

    Ansonsten weiß ich auch nicht mehr weiter. Bräuchte da mal ein wenig Hilfe bei der Lösung ;)

    Mein Rechner setzt sich wie folgt zusammen:
    Asus P7P55D-E
    Intel Core i5 760
    8GB DDR-3
    Geforce GTX 470
    OCZ Revodrive SSD

    Freue mich auf Antwort ;)
    MfG

    • Hi, nach den Suchtreffern in Serverlog sehe ich, dass du schon länger auf eine Antwort wartest. Sorry, hatte die Tage viel zu tun. Also, generell ist es leider so, dass Flash unter Linux nicht gut läuft. Flash kann nach wie vor nicht die GPU zum Rendern der Grafiken/Videos verwenden. Daher lastet alles auf der CPU, die leider gut durch Flash ausgelastet wird.

      Dein Rechner sollte aber defintiv fit genug sein, um auch Flash mit der CPU rendern zu können. Ich habe einen i3 und dort klappt eigentlich alles flashige – selbst im Vollbild – ruckelfrei. Bei der Flash-Installation kann man heute eigentlich gar nichts mehr gross falsch machen. Es klappt ja alles automatisch. Was für eine Flash-Seite macht denn die Probleme?

  41. Pingback: Probleme mit Adobe Flash in Ubuntu mittels Flash-Aid lösen | Linux und Ich

Hinterlasse eine Antwort

Auf Linux und Ich darf anonym kommentiert werden. Die Felder für Name und E-Mail-Adresse dürfen beim Eintragen eures Kommentars leer bleiben. Ich freue mich aber über jeden Kommentar, zu dem der Autor mit seinem Namen steht.