TEILEN
Mittwald: Webhosting. Einfach intelligent.

Vielleicht mal ein schneller Tipp für alle, die gerade dabei sind ihr Ubuntu-System zu aktualisieren bzw. die diese Arbeit schon hinter sich haben. Alin Andrei vom WebUpd8-Blog hat seinem Y PPA Manager eine Funktion spendiert, die besonders nach einem Upgrade auf die neue Ubuntu-Version von Nutzen sein kann. Im Laufe des Upgrades werden ja sämtliche zusätzliche Paketquellen deaktiviert. Wer mehr als ein nur paar PPAs im Einsatz hat, der muss nach dem Upgrade bei jedem PPA überprüfen, ob dieses schon für Oneiric aufbereitet wurde und dieses dann neu zur Paketverwaltung hinzufügen.

Der Y PPA Manager für Ubuntu

Der Y PPA Manager kann einem nun diese Arbeit abnehmen. Nach dem Upgrade kann man über den Advanced-Button sagen, dass alles zuvor deaktivierten PPAs wieder aktiviert werden sollen. Das Programm macht dies nicht einfach blind, sondern überprüft ob jedes PPA auch wirklich schon für Oneiric zur Verfügung steht. Fällt der Check positiv aus, dann wird die Quelle wieder aktiviert und natürlich der zur aktuellen Ubuntu-Version passende Zweig eingetragen.

$ sudo add-apt-repository ppa:webupd8team/y-ppa-manager
$ sudo apt-get update && sudo apt-get install y-ppa-manager

Ich persönlich hätte die Funktion nach dem Upgrade meines Rechners – auf dem ich zugegeben viel zu viel experimentiere – ganz gut gebrauchen können. Jedes einzelne PPA durchzugehen und es von Hand wieder zu aktiviert hat mich schon ein Stündchen gekostetet. Mit der neuen Funktion des Y PPA Manager wäre das garantiert schneller von der Hand gegangen.

Allerdings würde ich nach einem Upgrade nicht blind wieder jedes PPA aktivieren, selbst wenn es schon für die neue Version aufbereitet wurde. So ein Upgrade würde ich immer zum Großreinemachen bei den genutzten PPAs nutzen. Eventuell ist das PPA ja gar nicht mehr nötig, weil das Programm schon direkt in den Quellen von Ubuntu aktualisiert wurde etc.

 

7 KOMMENTARE

  1. Kann mir einer bei Keepass weiterhelfen?

    Es ist eine neue Version erschienen 2.17, wie kriege ich die installiert? Verwende Lubuntu 11.10 x64

    So wie ich das verstanden habe, soll man nun wieder kopieren können.

    • Das PPA für Keepass wurde wohl noch nicht aktualisiert. Es gibt es weder für Oneiric, noch steckt dort die Version 2.17 drinnen. Am besten abwarten und Tee trinken, du kannst ja probieren ob sich die 2.16 aus Natty von Hand installieren lässt.

      Grüße
      Christoph

  2. Auf meinem Netbook läuft 11.10 schon, bei meinem Desktop werde ich noch etwas warten und schaue wie sich das in den nächsten 2-3 Wochen so entwickelt.

  3. ich Installiere lieber neu ,dauert genau so lange und ich habe keine Altlasten,ich habe mal ein Update gemacht danach ging nichts mehr ,Trotzdem ein Toller Bericht

    • Kann ich verstehen, aber ich habe *durchweg* nur gute Erfahrungen mit Upgrades von Ubuntu-Installationen gemacht – außer die neue Version verträgt sich mit einer Hardwarekomponenten nicht, ich spreche vom reinen Upgradevorgang. Und ich denke man glaubt mir, dass ich VIEL VIEL auf meinem System verändere 😉 Mein aktueller Rechner hier wurde mit Lucid installiert und hat Upgrade auf Upgrade erhalten. Ein Homeserver habe ich sogar von Ubuntu Breezy bis Hardy gezogen, dann hat sich leider das Netzteil rauchend verabschiedet…

HINTERLASSEN SIE EINE ANTWORT